Menu

Help Center

[Windows] Installer Errors

Follow

Comments

179 comments

  • Avatar
    Lathoran

    Unable to install at all. I keep getting an "Entry Point Not Found" error referencing "SHELL32.dll"
    I'm using Vista x64 Home Edition.

  • Avatar
    Asciel

    I think my problem is the same as Lathoran. I'm also on Vista. Every time I try to run the installer, I get this message: "The procedure entry point GetCurrentProcessExplicitAppUserModelID could not be located in the dynamic link library SHELL32.dll."
    Please help!

  • Avatar
    Maksa (Edited )

    Delete this comment!

  • Avatar
    maimegidola

    What I needed to do to make sure the reinstall worked is open Task Manager and make sure all instances of Discord were closed, check apps and background processes.

  • Avatar
    Maksa

    There is no other instances of Discord.. When i close program that is failing to update, there is not anything left in Task Manager related to Discord. I tryed again with reinstall and changing compatibility and it doesnt work. I guess app is not good, its alpha and i dont understand why owner dont fix this stupid bug.. I use w10 64bit, and there is problem.. So FIX it..

  • Avatar
    MicrosoftDotCom

    Useless program :(

  • Avatar
    420blazing#swag9001

    1st "No route" and day after it fixed it self "update fail", at this pace I'm going to run in to every bug. I guess I will stick to the browser.

  • Avatar
    Vastra

    This doesn't work, followed all steps to the letter, the app just doesn't work after an update is available, this loop has been continuing for an entire day now. I give up. Win7 64bit, all .NET updates installed, even optional.

  • Avatar
    PixelBurst

    Just as an FYI disabling real time scanners (360 Total Security in my case) fixed this issue.

  • Avatar
    Roman

    take me off this email list. I'm tired of getting notifications when people complain!

  • Avatar
    ramsus

    f you get stuck in an update loop - go to the following directory and delete the file named something like this. Just look for the .squirrel file and delete it. This let the program through. See the bottom for the actual error message
    C:\Users\"yourusername"\AppData\Local\Temp.squirrel-lock-8B2CDBB25344C25CE1187D2156990F9C89878F8E

    SingleGlobalInstance: Failed to grab lockfile, will retry: C:\Users\username\AppData\Local\Temp.squirrel-lock-8B2CDBB25344C25CE1187D2156990F9C89878F8E: System.IO.IOException: The process cannot access the file 'C:\Users\username\AppData\Local\Temp.squirrel-lock-8B2CDBB25344C25CE1187D2156990F9C89878F8E' because it is being used by another process

  • Avatar
    SkullyGamingMC
    It isn't allowing me to delete the folders, it says they are currently being run in a program but I have nothing running
  • Avatar
    ramsus
    I think the name of the program was updater.exe that you might have to kill in task manager.
  • Avatar
    Grendel
    I too had this error, but before trying anything mentioned above, I restored my HOSTS file to stock. Thought it might be being blocked. Once I did that, without any other changes, it worked Windows 10 64Bit.
  • Avatar
    Weez
    Can't install!!. Still getting unable to write!! Did all the deletes and uninstall as previous posters have done. Turned off antivirus. rebooted.. windows 7.
  • Avatar
    ZinGahhhhhhhhhhhhhhhhhhhhhhh
    Me and my mate just found a fix for not being able to delete the folder in the Local Appdata. What was happening, if this is happening to you is that it says you cannot delete the folder because discord is already running when it really isn't. What we did was open the task manager (Ctrl+Atl+Delete) and click the button that says more details if it already isn't expanded and scroll down to background processors, for us there was 4 discord entries, just delete all of them no matter how many there are. Now go back to the Local Appdata folder for discord and you will now be able to delete it. You should be all good from there to redownload and start chatting shit with your mates again.
  • Avatar
    maimegidola
    I commented once on this thread, and now I keep getting emails every time someone posts a comment. How do I unsubcribe from this thread? The email spam is getting irritating, quite frankly.
  • Avatar
    Kakkis
    4/25 found this helpful :/
  • Avatar
    timebot

    I remembered that I have blocked access to Update.exe in the firewall, problem solved for me :D

  • Avatar
    b0c1

    I think I got the problem (in here)

    The application based on electron and react (I extracted and checked in the asar file). The main problem is the cloudflare protection. When you visit the discordapp.com you may got a google chapcha request. The cloudflare try to block ip addresses and require google captcha to unlock for that session.
    And this is the problem. The application conenct to the server using standard https connection and the server blocked (http 403) because you must fill the chaptcha.

    And now you are in the trap. You must fill the chaptcha, but you can't see because it's a programatic background request, you not see it (the application work as a http browser without window)

    Possible solution:
    - Report it to your administrator to solve the issue...
    - Ask the developers: when the api got error code 403, open a browser window in same session when you can "solve" the captcha (in electron you can catch the redirect, and close this window, and recall the original api request).

    That's all folks

  • Avatar
    McKillem

    For those still struggling, try adding the %LocalAppData%/Discord folder to the list of exceptions in your anti-virus software. One of my friends solved the problem this way, anti-virus never even reported blocking the updater.

  • Avatar
    b0c1

    I'll try but I using notebook and at home this issue not exists... just in my work network, but tomorrow I'll try to do that, thnx

  • Avatar
    b0c1

    Tested with and without AV. Same result... I got the same problem with many site like spring.io, codefights.com, livecoding.tv, www.cloudflare.com, etc... all is protected by cloudflare

  • Avatar
    iamwpj

    I solved this for myself by connecting to my phone as a hotspot. I have one computer with with TrendMicro, business AV and another that is just Windows Defender defaults (both Windows 10 x64). My router is a consumer Netgear, no special settings set.

  • Avatar
    Schwippity McSchwip MC Motorboat

    b0c1 got exactly what is going on with my setup.
    Currently I am added to a blocklist because my IP was registered as a spambot host, malware which I removed a couple days ago.
    https://support.cloudflare.com/hc/en-us/articles/203366080-Why-do-I-see-a-captcha-or-challenge-page-Attention-Required-trying-to-visit-a-site-protected-by-CloudFlare-as-a-site-visitor-

    Now since I am on a blocklist, CloudFlare is currently forcing captchas on me for every site they host (who has a security option enabled) until they whitelist/remove me from the blacklist. How long the period is is unknown to me, but I'm supposedly up to day 5 without any malicious/suspicious activities and hopefully it will reduce my threat score to a 0 at day 7 (currently at threat level 36).
    http://www.ip-tracker.org/blacklist-check.php

    A workaround:
    Use the web based app and ignore the desktop for now. Scan your computer for any malware and wait.

    Some currently-not-possible solutions:
    Discord has the ability to reduce or remove the captcha, but that seems to not be a safe option:
    https://support.cloudflare.com/hc/en-us/articles/200170096-How-do-I-turn-the-CloudFlare-captcha-challenge-page-off-
    Discord may also personally check and add IPs to a whitelist.

    In the end, sticking with the web based discord for now and waiting until I can past the updater.

  • Avatar
    SGTNipplez

    I've been trying to install the discord app onto my laptop which runs windows 8.1. I keep getting the same error saying "Installation has failed. There was an error while installing the application. Check the setup log for more information and contact the author." when i try to open the setup log though, nothing happens. I also have neither an %appdata%/discord folder nor a %localappdata%/discord folder. The program does not show up in the list when i go to uninstall it through the control panel, and i have tried running the setup program as administrator, and the same thing happens.

  • Avatar
    LennyNoLennie

    I'm having the same issue, but whenever I try to delete the folders, it won't let me. Whenever I try to delete the roaming folders, it will say that there is an error, or that the app is still running. So I open the taskbar, but Discord isn't there. Does anyone have a solution for this problem? It would be an amazing help for me, thank you.

  • Avatar
    D3

    Literally the only way I got this fixed was.... system restore.

  • Avatar
    Stephinci [Brenxir]

    What seems to work for me everytime is deleting the %AppData%/Discord (roaming). But keeping the localdata. And restarting discord. You'll have to login again, but at least I got it working again like this.

  • Avatar
    maolmuaidh

    any chance to make it compatible with ms edge

Article is closed for comments.